Di Blasi r7 headlight only working intermittently

When I started the bike for the first time it ran fine and everything but I noticed the headlight and turn signals were not working. After riding for a while the turn signals started working (both front and back) but the headlight would cut on and off. I don’t know what connections to check. When it works it shines good and bright so the bulb is good. When I hit bumps it seems to come on and then turn off after a little bit. All of the other electrical stuff works good (horn, turn signals, tail/brake light, etc) but the headlight doesn’t work all the time

Re: Di Blasi r7 headlight only working intermittently

Largemouth Bass /

Bump

Re: Di Blasi r7 headlight only working intermittently

Just look at what wires go to the headlight. Note their color, look for any place where those color wires connect to other wires, make sure they're tight. It's gotta be a loose connection somewhere.

Re: Di Blasi r7 headlight only working intermittently

I had that problem I'm a Hobbit once, turned out that the ignition and light were being ground to the same spot

Re: Di Blasi r7 headlight only working intermittently

Largemouth Bass /

> Nick Haber Wrote:

> -------------------------------------------------------

> Just look at what wires go to the headlight. Note their color, look for

> any place where those color wires connect to other wires, make sure

> they're tight. It's gotta be a loose connection somewhere.

This problem just got even weirder. The normal headlight started working but the "brights" don't. Sometimes it flickers a little when I'm going over bumps and stuff and sometimes it even comes on. I've checked all the connections I can think of but I'll look again.

Re: Di Blasi r7 headlight only working intermittently

Largemouth Bass /

> mo pug Wrote:

> -------------------------------------------------------

> I had that problem I'm a Hobbit once, turned out that the ignition and

> light were being ground to the same spot

How would I go about looking for that? I see one ground on the frame but all the wires are inside this stupid sheath thing and its hard to trace them. Thanks for the reply!

Re: Di Blasi r7 headlight only working intermittently

I'd be suspecting the headlight bulb .

Maybe an internal defect .

Test it independently and shake/jar/bump it when testing .

Re: Di Blasi r7 headlight only working intermittently

Largemouth Bass /

> P D Wrote:

> -------------------------------------------------------

> I'd be suspecting the headlight bulb .

>

> Maybe an internal defect .

>

> Test it independently and shake/jar/bump it when testing .

thought so too but there is only one bulb and it works on the low setting

Re: Di Blasi r7 headlight only working intermittently

> Largemouth Bass Wrote:

> -------------------------------------------------------

> > Nick Haber Wrote:

>

> > -------------------------------------------------------

>

> > Just look at what wires go to the headlight. Note their color, look

> for

>

> > any place where those color wires connect to other wires, make sure

>

> > they're tight. It's gotta be a loose connection somewhere.

>

> This problem just got even weirder. The normal headlight started working

> but the "brights" don't. Sometimes it flickers a little when I'm going

> over bumps and stuff and sometimes it even comes on. I've checked all

> the connections I can think of but I'll look again.

Assuming the high beam part of the bulb isn't burnt out, I'm willing to bet that this is an issue with your electrical controls. I have a CB550 that has some loose connection or something in the hi/lo beam control, so my headlight will cut out if you touch the switch at all and it's a pain to get it to come back on. Take apart your controls, clean contacts, make sure no wires are uninsulated and rubbing together.

Re: Di Blasi r7 headlight only working intermittently

Largemouth Bass /

> Nick Haber Wrote:

> -------------------------------------------------------

> > Largemouth Bass Wrote:

>

> > -------------------------------------------------------

>

> > > Nick Haber Wrote:

>

> >

>

> > > -------------------------------------------------------

>

> >

>

> > > Just look at what wires go to the headlight. Note their color, look

>

> > for

>

> >

>

> > > any place where those color wires connect to other wires, make sure

>

> >

>

> > > they're tight. It's gotta be a loose connection somewhere.

>

> >

>

> > This problem just got even weirder. The normal headlight started

> working

>

> > but the "brights" don't. Sometimes it flickers a little when I'm going

>

> > over bumps and stuff and sometimes it even comes on. I've checked all

>

> > the connections I can think of but I'll look again.

>

> Assuming the high beam part of the bulb isn't burnt out, I'm willing to

> bet that this is an issue with your electrical controls. I have a CB550

> that has some loose connection or something in the hi/lo beam control,

> so my headlight will cut out if you touch the switch at all and it's a

> pain to get it to come back on. Take apart your controls, clean

> contacts, make sure no wires are uninsulated and rubbing together.

Are you talking about the switches on the handlebars? I will take a look at them after work tonight

Re: Di Blasi r7 headlight only working intermittently

> Largemouth Bass Wrote:

> -------------------------------------------------------

> Are you talking about the switches on the handlebars? I will take a look

> at them after work tonight

Yep, that's what I'm talking about

Re: Di Blasi r7 headlight only working intermittently

> Largemouth Bass Wrote:

> -------------------------------------------------------

> > P D Wrote:

>

> > -------------------------------------------------------

>

> > I'd be suspecting the headlight bulb .

>

> >

>

> > Maybe an internal defect .

>

> >

>

> > Test it independently and shake/jar/bump it when testing .

>

> thought so too but there is only one bulb and it works on the low

> w setting

One bulb with TWO filaments .

Re: Di Blasi r7 headlight only working intermittently

Largemouth Bass /

Ohhh I thought it just sent more power to the same bulb. It would sometimes come on for a second and flip back off. I looked at the filament and it wasn’t broken or anything. I’m hoping it’s simply a loose connection somewhere.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account