Tomos Sprint no spark please help!! :*(

I have a new tomos sprint I just bought a few months back. I left it out in the rain a couple days and now all of a sudden it has no spark. The horn and lights work when I crank the engine, but I get no spark. What could be the problem?? I can't figure it out :(

Re: Tomos Sprint no spark please help!! :*(

Search for new tomos ignition failures...could be a sensor or a cdi box. Isn't it still under warrantee? Contact the dealer and tell em' about the problem...

Re: Tomos Sprint no spark please help!! :*(

Why are you surprised your bike doesn’t start after being left in the rain. Sounds normal to me. The new tomos are no good

I hope you have good luck with it

Re: Tomos Sprint no spark please help!! :*(

♣Slew Foot♣ /

Yeah there's an electrical fault somewhere could be a loose wire could be a buried wire that. Pinched there are a thousand things that could go wrong and I hate when people just start saying all its crappy this crappy that anytime I buy something I go over the whole damn thing my guess as to why it doesn't work after being left out in the rain would be the kill switch is wet and grounding against the bars no manufacturers flaw just an idiot

Re: Tomos Sprint no spark please help!! :*(

♣Slew Foot♣ /

sorry that was kind of raw of me but if you have ever bought a used moped you would know this no moped is reliable

If you put in total hours used to design a car so that it starts every time you turn the key you could have built the pyramids three times over so next time your bad mouth a product can you make one better yourself

Re: Tomos Sprint no spark please help!! :*(

Should I disconnect every single wire (lights, on/off switch, horn) and see if it starts with only the ignition coil connected? Also, do you think it's possible the CDI somehow got fried in the rain? Because I did order a replacement for it after I couldn't figure out the problem.

Re: Tomos Sprint no spark please help!! :*(

♣Slew Foot♣ /

No just the kill switch or you can just dry it out with a hair dryer

Re: Tomos Sprint no spark please help!! :*(

Didn't we just have one guy that had a powder-coated ground connection he had to clean off on a new Tomos?

Saw a key switch go bad once . Not sure which wires hook into it on the new Tomos.

Also,I carry a new CDI in my StreetMate that I've had in the tool bag since `05.

Have 2nd stroke send you a new CDI. Pay them for it if it's not the problem,and keep it in your tool bag.

Re: Tomos Sprint no spark please help!! :*(

Probably Fred /

> ♣Slew Foot♣ Wrote:

> -------------------------------------------------------

> sorry that was kind of raw of me but if you have ever bought a used

> moped you would know this no moped is reliable

>

You must have never got a low mileage puch or bought a non-abused puch moped for I had/worked on over 100 of them and I still have several,

They are the most simple (78-82 6wire Stator with plastic switches models) and reliable bikes ever, even kitted,

If you start out with the bike that was never abused to begin with most any brand of moped (including tomos) you will/could have a reliable bike

My personal bikes I built and kitted 10 years ago and they still work perfect, of course I do maintenance per the manual/yearly maintenance check, change plug, bulbs tires, sprockets and chain if they wear out, check/replace rings every 5k mi etc.

There’s nothing wrong with doing a one minute walk around before you takeoff on your bike to check for chain tension, tire air pressure, gas leaks, working lights etc. if you do that religiously your chances of breaking down with most bikes will be minimal,

If your bike gets caught in the rain blowing the switches out with a air hose right after it happens most times get you going again,

Bring plastic bags and rubber bands to cover the switches if your bike has a problem in the rain or change the switches to more waterproof ones,

Once you know the limits of your bike you can re-engineer something simple that makes your bike very reliable

Re: Tomos Sprint no spark please help!! :*(

Yep! My mopeds, Morini,Minarelli, and StreetMate are always reliable. Lightly kitted and a little over-jetted RATHER than under-jetted is the key,along with good quality 2-stroke oil at 40:1 or more oil ratio.

Went to Ike's Bikes Ride once. That's 82 miles one way on back roads. Sebring blew a clutch shoe link. Got it to Ike's Ride, and rode a few miles,then offered my apologies and rode the 80+ miles home. So over 160 miles that day on a `broken' moped. LOL!

Re: Tomos Sprint no spark please help!! :*(

♣Slew Foot♣ /

I've had quite a few bikes and a puch among them it is all good till the clutch goes.

An m48 is simplicity...

. It could be the electronic trigger that's in the stator side engine case

Re: Tomos Sprint no spark please help!! :*(

Yeah idk I still can't figure out whats going on. I unplugged the on/off switch and still no spark. Everything is dry by now, left it in the sun 2 days. I ordered a new cdi ignition coil hopefully that fixes the issues. Should arrive by Friday. If not, I'll have to get a new magneto I guess.

Re: Tomos Sprint no spark please help!! :*(

♣Slew Foot♣ /

Dollars to Donuts it's most likely the trigger unit the coils usually don't go bad neither do the internal ignition coils 8 out of 10 times it's going to be the trigger unit that being said also the CDI box has to match the stator if it's an older one it doesn't take the trigger unit instead it has a hall effect sensor built into the ignition coil I have seen those go bad but CDI boxes I don't think I ever had one that was broke when you rewired it after disconnecting everything are you sure you put everything back where it was if you run the trigger through the regulator box it won't work if your ground isn't close enough to the Box it can foul the spark. If you take out the spark plug and hold it against the side of the head when you turn it over do you get any Spark?

Re: Tomos Sprint no spark please help!! :*(

Yeah I rewired everything correctly. If I take out the spark plug and hold it against the head of the engine I get absolutely no spark. When you say "trigger unit" you're talking about the little sensor that sits right on the outside of the flywheel that has a black wire and white wire coming out of it right? You think that is what most likely has failed?

Re: Tomos Sprint no spark please help!! :*(

♣Slew Foot♣ /

. Yeah if it if it was left out in the rain and it doesn't work that very well could be the culprit cuz water can get in there but I wish I was on the other coast because I could look at it and in 10 minutes I can figure out what the hell was going wrong

Re: Tomos Sprint no spark please help!! :*(

I uploaded this short video to youtube showing the wiring of my moped. Let me know if you see anything wrong or have any suggestions. This is how it came stock, although I've messed with it a bit but always put everything back how it was originally.

Re: Tomos Sprint no spark please help!! :*(

u figure it out yet? pretty much the easiest bike to fix this....if all else fails, treats sells the actual awesome cdi that goes on it.

i have a similar setup. you're dealing with a wire touching or not touching something it shouldn't. highly unlikely anythings wrong with a factory tomos cdi...it does have tomos cdi, like it should, right? new plug recently? look for misbehaving wires. new spark plug. check back here. in that order. u know how to check for spark the easy way right?

Re: Tomos Sprint no spark please help!! :*(

Yeah everything is stock. For some reason I just can’t figure it out. I’ve tried various plugs, pressing them onto the head. Tried bypassing the on/off switch too. Can’t get this thing to start.

Re: Tomos Sprint no spark please help!! :*(

I’m tellin ya man, it’s the new a55 stator/flywheel. they just shit out after a minute because tomos went full juggalo and said “magnets how the fuck do they work?” grab the cdi off a revival or something, just had to do this for my dad’s racing tt

Re: Tomos Sprint no spark please help!! :*(

Dirty30 Dillon /

If you haven't replaced the Stator, then your problem will persist.

Re: Tomos Sprint no spark please help!! :*(

♣Slew Foot♣ /

Yeah the wire that comes off the Magneto the black one go straight to the coil the other end goes to the kill switch you have to bypass the kill switch if you just took that off it didn't get a trigger signal

Re: Tomos Sprint no spark please help!! :*(

Guess what guys, I fixed it! I replaced the cdi ignition coil on my lunch break and now I have spark and it's running like a champ!

Re: Tomos Sprint no spark please help!! :*(

Way to go man! Still highly recommend replacing the flywheel if you haven’t already

Re: Tomos Sprint no spark please help!! :*(

Why the flywheel, if you don't mind me asking? It's just a metal drum basically, nothing can go wrong with it. Or are you talking about the magneto inside the flywheel.

Re: Tomos Sprint no spark please help!! :*(

It’s long and complicated but like I said on your youtube vid tomos fucked up (or at least their parts supplier did) and provided a flywheel with polarity that roasts the stators after a while. Listen to Pete from second stroke’s episode of moped Monday podcast if ya want the full lowdown

Re: Tomos Sprint no spark please help!! :*(

Glad you got her going!

Makes me feel better about carrying that extra CDI for the last 14 yrs. LOL!

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account