Points won’t open

I’ve a 79 Puch Newport that I’m rebuilding, and I’m trying to time the engine for the first time since I’ve owned it. The bike runs and was running (albeit poorly) before I moved the stator plate, but ever since I tried to adjust it, I’ve been having a hard time getting the points to open - even after tightening them with proper cardboard in between. I don’t think they’re shot, I’ve tried to do my research on this as well, and I’m not finding answers for how to get points to open when you rotate the flywheel. Help?

Re: Points won’t open

Josiah Radebaugh /

Loosen the screw and turn it so the little pad it further in towards the center of the flywheel.

Re: Points won’t open

Is the little cam follower tip on the points still there? Its made out of a sort of hard plastic and could potentially be worn down or broken off.

Re: Points won’t open

What Saab said usually happens when the flywheel has rust on the cam area acting as high speed sandpaper

Re: Points won’t open

♣Slew Foot♣ /

The older cev flywheels are hard to set if that feeler foot looks okay what next time you go to set it put at the bottom dead center let the Fila foot fall all the way down bottom dead center is the low spot on the flywheel lobe so theoretically if you let it close on the lowest spot it will open when it hits the right part of the lobe

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account