carb is clean but no gas goes to the engine. HELP

i have a honda express. carb is clean, fuel lines are clean. the moped will not start, i took the spark plug out to see if mist comes out of the hole and it doesn't. what is wrong?

Re: carb is clean but no gas goes to the engine.

Pea Shooter /

check gas tank, if its dirty/rusty. also buy fuel filter.

Re: carb is clean but no gas goes to the engine.

it used to have an auto oiler thing, now the tank is messed up and i have to put mixed gas in there. but i don't think its too rusty. and when i try to start the moped, gas will come out of the float bowl over flow thingy.

Re: carb is clean but no gas goes to the engine.

Reeperette /

Stuck Float, or Clogged main jet too.

-R

Re: carb is clean but no gas goes to the engine.

i know the main jet is not clogged, i cleaned it out and i can see strait through it. if the float was stuck, how do i get it working again?

Re: carb is clean but no gas goes to the engine.

Reeperette /

Well, check how it works by actuating it in place and makin sure it works smoothly...if it does not, try scubbing it with a medium stuff brush (the "toothbrush" that comes in gun cleaning kits is ideal) and some kerosene.

-R

Re: carb is clean but no gas goes to the engine.

i took the cap of of the oil part of the gas tank and i started getting mist out of the exhaust. when my friend took it to a shop 2 years ago they said the auto oiler was messed up and they connected the oil tube to the carb and disconnected the fuel line and turned of the petcock. anyways, the oil cap doesn't have any vent holes so thats why i wasn't getting any gas. but mist only comes out of the exhaust and not out of the spark plug hole, the engine does not start either. i think it has compression lost but shouldn't it start with crappy compression? what might be other reasons my moped won't start? it has a brand new spark plug.

Re: carb is clean but no gas goes to the engine.

Did you even try to clean your float like ree said to? If your carb is flooding, it's your float dude.

Re: carb is clean but no gas goes to the engine.

peashooter /

Your float may be bent. To check, take the bottum off of your carb. But keep it all hooked up to the fuel line. Open your petcock valve to let fuel into the carb. and the little plug that is normally connected to the float. Take that and just push it up into the hole with your hand (as in the float is completely off of the carb.) If this stops the gas flow then maybe your float is just not set at the right level (if it doesnt stop the gas flow, then u may be screwed. I really dont know if that can be fixed), it may be bent. Somehow just get it to the right level so that the float will push up on the little pin enough to completely seal the hole where fuel comes into the bowl. This was a problem in my Puch. Another thing is, does gas overflow and leak out of your carb's bowl, this is another way to tell that the float probably isnt on the right level.

I probably dont know what I am talking about, but i did this on my puch and it worked. (as in it doesnt overflow and it does take in fuel.) But my puch dont idle, i think becuase i need to clean the jets.

so this is just an idea, but u should prob get advice from someone else.

pea shooter

Re: carb is clean but no gas goes to the engine.

yeah, the gas leaks out of the bowl. i'll check out the float and see what i can do. thanks for the advice.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account