What the hell is wrong with my BiTurbo Pipe?

I bought a Biturbo pipe and it doesent work, its hard to get my tomos targa lx to start and when it does unless I am pulling the accelerator the bike shuts off. also after running my bike for less than 2 mins the bike shuts off and wont kick start. I put the old stock tomos pipe and now it runs great, If any one has any explanation for my prolem or any ideas please respond. thanks

Re: What the hell is wrong with my BiTurbo Pipe?

do I need to add any other parts to make the pipe work and not damage my tomos?

Re: What the hell is wrong with my BiTurbo Pipe?

You probably need to put a bigger jet in your carb...Those pipes lean out your gas/air mixture. A super lean ped could be hard to start, and run like crap.

Re: What the hell is wrong with my BiTurbo Pipe?

SO what exactly do I need to purchase for my moped?

Re: What the hell is wrong with my BiTurbo Pipe?

a carb jet 2-3 sizes bigger than stock. Whatever that may be.

WAIT! see if its blocked up!

blow some compressed air through the pipe and make sure its not blocked up, pull out the packing in the silencer end and check with a flashlight in there too, sounds like theres somthing blocking the pipe (like a piece of packing) also you could try running somthing through the pipe, like a heavy piece of wire, just make sure its clear. had a similar problem with my honda mini trail when i was lil, only to find there was a big dirt clod cemented in the end of the muffler! :P

-Garret

Re: What the hell is wrong with my BiTurbo Pipe?

Ron Brown /

Brian,

Look in Fred's guide for "plug chop". This will explain how to select the correct jet size.

Ron

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account