grande, bad acceleration

My grande runs great and idles great but when I accelarate from a stop (while idling), it kind of jerks and shakes, like something's slipping, and then starts going. I dont think its the starting clutch, but maybe the drive clutch/pully? It has a new belt, greased variator, and the tranny has adequate gear oil.

Re: grande, bad acceleration

are the bolts on the swingarm tight? Is it easy to start?

Re: grande, bad acceleration

yeah it's easy to start. what's the swingarm?

Re: grande, bad acceleration

Check your three motor mount bolts to make sure they are tight.

Check the rear wheel mounting bolts to make sure they are tight (4 hex head bolts, 2 on each side).

Make sure the sub frame bolt holes for the rear wheels are not broken or torn.

Re: grande, bad acceleration

alright, i'll do that and see if it helps

thanks

Re: grande, bad acceleration

Also make sure the locking nut on the front speed regulator is tight and the locking washer is bent over so the nut won't come undone

Make sure you don't have grease in the pulley areas (front and back) and no grease on the belt. You can use a solvent like brake cleaner or electrical contact cleaner to clean the belt if it has grease on it.

Re: grande, bad acceleration

Yeah, all of that checks out ok, and I checked all of those bolts and they were tight. I also noticed something else. When it's on the stand and I give it gas, it doesn't jerk or anything. But, I tried lightly holding the brake (to simulate resistance on the back wheel), and I could clearly see the clutch kind of jerking, too. Another thing; when I turn the clutch with my hand, it feels as if it has a lot of play in it. Maybe something's wrong in the tranny?

Thanks for the help.

Re: grande, bad acceleration

Check the tranny for oil. Screw or hex head nut near the Free Wheeling button. If oil runs out you are OK, If not use 80-90 weight gear oil. Buy the Gera oil in the plastic bottle with the nose cone, makes it easy to fill the tranny.

Re: grande, bad acceleration

Yep, just filled it a couple of weeks ago.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account