Ign. switch needed/ spark problem

Billy Bob /

Need handlebar mounted ignition switch w/ key for Bianchi moped. Please e-mail countchocula@forpresident.com if you have something that will work.

Also, I don't seem to be able to get a spark out of this thing. I crimped the two wires (where the ignition switch was) together, but I still don't seem to get a spark registering on my voltmeter when I kick the thing over. Can someone tell me what I should trouble shoot? I'm not very familiar with mopeds.

Re: Ign. switch needed/ spark problem

Ron Brown /

Billy Bob,

If your moped is like most, you have done exactly the wrong thing by connecting th wires together.

Read Fred's "How to fix your moped" under Resources, Articles.

If you need more, here are my generic ignition checking instructions.

If you have a vom, check the ignition components as follows:

Disconect the wires from the points. One of these wires goes to the magneto ignition power coil. You should read a low resistance to ground on this wire, 1-2 ohms.

Another wire goes to the condensor, read this to ground on RXMAX, that is your highest resistance range, the needle should kick, then settle down to infinity. Reverse the vom leads, same thing should happen.

Another wire goes to the ignition coil primary, this connection is also connected to the kill switch. Disconnect the kill switch wire only from the ignition coil, the wire to the coil should read 1-2 ohms to ground.

From the wire to the kill switch, to ground, you should read infinity with the switch in "run" and 0 ohms with the switch in "stop".

Connect the vom from ground to the wire terminal on the points and make sure they are 0 ohms when closed and infinity when open. This seems dumb, but sometimes points that look clean do not connect.

Re-attach all of the wires to the points. Disconnect the wire from the points at the ignition coil. Measure this with the vom, it should read near 0 ohms. If your meter is sensitive enough, you should see a slight deflection of the pointer as the points open and close.

With the vom still attached and set to about 12v DC range, spin the motor by hand. You should see some deflection of the meter needle.

Pull your plug (spark, that is) and make sure the piston is at or very near the top of it's stroke when the points open.

Re-connect the coil wire. Measure from the plug cap to ground, you should read 5-15k ohms. If this is infinity, unscrew the plug cap from the wire and read through it. This should be 5-15k ohms, if it is open, replace it, if greater than 15k ohms, it may still work, but replace it with a paper clip for test starting then re-install it after you get the ped running.

Read from the end of the plug wire to ground through the coil, you should see 1-5k ohms. If this is infinity, the coil is bad.

Lastly, using the ohmsX1 scale, verify that all of the grounds really are.

None of these tests are guaranteed to indicate a problem, especially where you read coil resistances and they seem ok. Substitution is the best test here.

To test the coil, connect a spark plug from the plug wire to coil ground, connect an ignition condensor (any will do for this test) between the points terminal and coil ground. Connect the negative of a 6V battery to coil ground and touch the points terminal momentarily with the positive lead. This should give you a spark at the plug.

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account