93 Sprint Won't Start

Sprint Man /

My friend has a light-blue 93 Tomos Sprint, and it won't start. He has a new spark plug and I don't know what could be the problem. I was guessing it needed a new piston kit, or it's just flooded. It doesn't have side panels, and he left it in the rain last night. We've been tryin to get it started half of the day.If you need more detail on what it looks like, there's a pic of it posted on this web site. Any on all help would be greatly appreciated.

Thanks

Re: 93 Sprint Won't Start

Reeperette /

Oh my....well, start with Freds Guide, make sure you have spark, fuel, and compression.

Spark and Fuel can be affected by water, you might have to dismount the carb and clean/flush it, and if your luck is really bad, some water got down into the cylinder or crank arm.

Best hope not, but start with the carb, cause it's likely you have water contamination in there.

And umm..when checking for spark? holding on to a wet spark plug while cranking is generally a BAD idea - tho you will KNOW if you have spark, that's fer sure - at that point.

-R

Re: 93 Sprint Won't Start

Sprint Man /

O.K, I figured out the problem, his ignition points or snapped, and he might need a new crank-shaft. We also need to get the fuel drained and put some fresh fuel inside. I also think the carb is dirty beacause it's under the chassis, and it's a little difficult to get to and hard to work on. That's why no one has messed with it.

Thanks Ree

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account