AV7 cylinder not fitting engine studs

I'm putting together an av7 witha biturbo kit. the cylinder slides onto the studs until an inch or so is left and won't go further. the engine studs have 2 sections that are a larger cross sectional area. the cylinder goes on fine through the first section but gets stuck on the second. should I machine my engine studs and turn down the thicker sections? has anyone else had this issue? thanks

Re: AV7 cylinder not fitting engine studs

2 potential issues i can think of:

a) are both the cylinder and bottom end AV7?

b) Do you have a "slow" (20mph) bottom end?

if so, theres a lip inside the cases that the cylinder skirt hits. i filed about 1 mm off the outer radius of the bottom 9mm of the cylinder skirt, but you could also dremel the case in a similar manner. i didnt take a pic, but i documented it here: link (edited)

Re: AV7 cylinder not fitting engine studs

One or more of your studs are slightly bent out causing the cylinder to catch.

Re: AV7 cylinder not fitting engine studs

Vova Fett /
ven OP

thanks for the help guys

Aaron, yup, I am 110% sure that both are AV7, and I have just determined it is NOT the skirt hitting the cases. I removed 1/4 studs and the cylinder went in fine. Unfortunately I may not have a camera until later today so I will just try to explain it. The two studs on the exhaust side are the ones causing an issue. Those extra thick sections on the studs is what the cylinder is getting caught on and it's what is restraining it from going further. I'll wait for a camera...going to go work on the intake gasket and printing out a degree wheel etc etc etc. I want to port and match this guy today.

Re: AV7 cylinder not fitting engine studs

maybe someone previously stripped out the threads on both of the "exhaust side" studs and then drilled+tapped for the next size up?

Re: AV7 cylinder not fitting engine studs

Vova Fett /
ven OP

oh motherfucker...if he did that....lol...it's okay, I have another av7 bottom end, and I could always grind down these studs. ALTHOUGH, it still seems like it's just those ticker sections being a pest. I got a camera from my roommate, let me charge it up and I'll take some photos. All four studs are the same as well.

Re: AV7 cylinder not fitting engine studs

Check the studs with a straight edge. It shouldn't be a big deal to get it to fit.

Re: AV7 cylinder not fitting engine studs

Just ream out the 4 holes in the cylinder 0.5mm and she will slide on like she should.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account