My Polini kit is lookin' good!

Hi,Everyone! I've been out and about on the Sebring since my last posting.I had just installed a new 60cc Polini kit I got from MopedWarehouse!It has 10.8:1 compression ratio and a reed valve(unlike the original cyl.).It's a 2-speed Franco-Morini engine.I started it up and ran it on the stand to warm it up a bit,whilst getting my gear together for a long trip.The weather was beautiful here in Ohio on Friday,so I took off!I stopped it two or three times at about 15 min. intervals and never went more than 2/3 throttle.I did 2 plug chops and all was fine,but power was lacking(seemed the same as my old 50cc cylinder)Then at about 20 miles into the ride or so............WHAM!Power came out of nowhere and I had to feather the throttle considerably,still topping 30mph!I did another plug chop `cause I was worried that the #58 jet might be too small.I had put a gallon of premium(93 octane)Marathon and went with a 37:1 ratio in it to ensure it would meet the compression reqs..So I'm REALLY PLEASED so far and I hope it keeps running super.I went 90 miles that day and got home way after dark,but no problems.The first few times I started the bike after thoroughly warmed up,I hadda choke it.ANY THOUGHTS,ANYONE!? Happy as a tick! Don (:^)

Re: My Polini kit is lookin' good!

hey don! way to go!

of course, i dont have any tips... =] just happy to hear its doing well for ya!

what sort of exhaust are you using on it? just curious..

casey

Re: My Polini kit is lookin' good!

Thanks!Well Casey,it's a stock exhaust that I decarbonized about 2000 mi. or so ago,but I did drill one extra hole in the end cap of it about 3/8" in diameter.When I put the kit on I checked it for backpressure and couldn't feel much,so I put her back on and away I went!HaHa! (:^)

Re: My Polini kit is lookin' good!

hey don sounds great. maybe you need to break her in alittle. enjoy!!!!!!!!

Re: My Polini kit is lookin' good!

Yeah,Paul! I can't wait to do that!But Fred has said,I think,that we don't have to run a whole 300 miles on just a bore kit installation.And the way that thing came to life,I feel it's nearly broken in at 90 miles.But I'll probably put another 50 on it before I hammer it good.Ha! (:^)

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account