Carburator-to-airbox hose fun (Spree)

Gros Pingouin /

In my 86 Spree, I found the hard plastic hose that links the airbox to the carb is not able to do that. If I put it properly in the airbox, it will not reach the carb and vice-versa. Now I wonder if the problem is a bent hose or something else... suggestions?

Re: Carburator-to-airbox hose fun (Spree)

Have you had the airbox off lately?

If ..Yes

Then you may have re-mounted it wrong.

One of the mounting tabs may be on the wrong sides of the bosses it mounts to

However.... Spree airboxes do tend to 'sag' away from the carb.

All the mounting screws need to be in place.

If that still doesn't work

Use some wire or duct tape to 'pull' it back into place.

And are you using the 'hoseclamp" that holds the boot onto the carb ?

Got to have that.

Re: Carburator-to-airbox hose fun (Spree)

Gros Pingouin /

> Have you had the airbox off lately?

>

Actually, I have never taken it off. Lazy, huh? =)

> One of the mounting tabs may be on the wrong sides of the

> bosses it mounts to

>

I will check that just in case the previous owner did not mount it right =)

> However.... Spree airboxes do tend to 'sag' away from the carb.

> All the mounting screws need to be in place.

>

Will check that

> If that still doesn't work

> Use some wire or duct tape to 'pull' it back into place.

>

The handyman's secret weapon? ;)

> And are you using the 'hoseclamp" that holds the boot onto

> the carb ?

> Got to have that.

Well, the clamp that was trying to hold the boot to the carb did not seem to be able to clamp tight enough to hold the boot in place. I guess I will have to find something similar but that works ;)

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account