Free Spirit runs like crap, again

chris /
This single post is part of a larger thread. Start from the top or view this post in context.

just when i thought that i finally had a decent, well-riding moped on my hands, my '82 Free Spirit just starts to freak out. so here's the scenario: it starts up just great and everything is fine. then after about 100 or so yards it starts to sputter and backfire. i thought it was the carb at first so i cleaned that thoroughly, and the problem went away for a little bit longer. but after a second test drive, the sputtering, bucking, and backfiring were back with a vengance. i checked the spark plug, which was brand new as of a week ago, and it was all black and sooty. i looked at that spark plug page in the resource section and it looks closest to being either carbon or oil fouled. i put yet another new spark plug in, and checked the air/fuel mixture, but after just one ride up and down the street, it was all black and greasy. the second spark plug looked like it was covered with something different than the first, though. i'm not sure if this is because the first plug had time to dry up and get all crusty, or if the substances on the plugs really are two different things. please help, i like this moped a lot. thanks!

==chris

This single post is part of a larger thread. Start from the top or view this post in context.
Subject Written By Posted
  Free Spirit runs like crap, againTopic by: chris chris 09/07/01 05:47PM
  Re: Free Spirit runs like crap, againRe: Reeperette Reeperette 09/08/01 12:46PM
  benny and the JETSRe: chris chris 09/08/01 02:03PM
  Re: benny and the JETSRe: Wayne Broderick Wayne Broderick 09/08/01 02:06PM
  haunted mopedRe: chris chris 09/08/01 02:47PM
  Re: Free Spirit runs like crap, againRe: ivan ivan 09/14/01 01:50AM
  Re: Free Spirit runs like crap, againRe: Ron Brown Ron Brown 09/14/01 02:22PM

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account