moped won't start anymore

This is in addition to the post that I posted yesterday. Thanks for all of your help. Today I took it around town and shut it off at the fair. I come back about fifteen minutes later and try to start it. I couldn't get it started. The engine wasn't even turning over. I took a look at the clutch while I was trying to start it and when pull the engager to engage the clutch, the clutch only turns once. I think that it is supposed to turn as much as you have the clutch engaged. I am just wondering because I have never had my own moped and I am not sure. Does anybody know where I can get the whole air filter assembly? Thanks for your help.

Re: moped won't start anymore

ummmm... u might have seezed ur engine... did u mix oil in with the gas? did u run it really hard? is the ari filter taken out?

Re: moped won't start anymore

Mike, I do mix 3 ounces of oil to one gallon of gas. I do run it as fast as it will go which is only about 25 mph. The sad thing is, is that when I bought it it did not have the airfilter or the silencer. How would I fix a siezed engine? or would I have to buy a new one? I hope I can fix it because I do not want to buy a new engine!!!

Re: moped won't start anymore

Ron Brown /

Jason,

Don't panic yet.

Peds almost never sieze while parked. Can you turn the engine over by turning the clutch by hand?

Bye the way, save us looking for your other posts, what the hell is it?

Ron

Re: moped won't start anymore

https://www.mopedarmy.com/forums/discuss/1/12876/12876/ this is the shortcut to my post that should go along with this post.

Re: moped won't start anymore

Ron Brown /

Jason,

Now I remember seeing the post, so what about my other question? Which can now include, or by turning the flywheel.

Ron

Re: moped won't start anymore

Ron, Yesterday I took some of the moped's parts of and started exploring the parts of the moped. I noticed that the bracket that holds the engine mounts was loose. I proceeded to take that bolts out and replace them with new ones because the old ones were stripped. After I got them tightened down I also noticed that the clutch belt was looser than it should be. So I found the bolt that made the belt get tighter and I tightened it up. The belt was also located on the same bracket. I put everything back together and when I went to start it up, it fired right up. So everything works fine except for when I come to a stop sign or to a stop it wants to stall. I think I need to adjust how much gas the moped gets. Well thanks for your help.

Re: moped won't start anymore

Ron Brown /

Jason,

Great!

Have you tried the idle screw?

Ron

Re: moped won't start anymore

Ron Brown /

Jason,

I forgot, Brian of mini-engines posted the number of a slip on filter for a Batavus a few weeks ago. You may find it by searching for AIr Filter.

Ron

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account