Now I did it!

josh /
This single post is part of a larger thread. Start from the top or view this post in context.

Its me again with the Yamaha Champ (basically QT50) that wont start despite having all of the needed essentials. Now I really screwed myself and am one step closer to giving up (man I really dont want to), I stripped the threads in the head by inserting and removing over and over again and using a plug that was not intended and turned out to have different thread spacing. Now what?! Not only can I not figure out my moped mystery, i cant even try now because my compression is shot as it leaks out around the threads. Should I try the liquid thread repair used for autos, ot search for new head. And by the way prior to this i STILL cant get my other problem discovered.

Josh

This single post is part of a larger thread. Start from the top or view this post in context.
Subject Written By Posted
  Now I did it!Topic by: josh josh 06/24/01 11:16PM
  Re: Now I did it!Re: gimmyjimmy gimmyjimmy 06/24/01 11:42PM
  Re: Now I did it!Re: Ron Brown Ron Brown 06/25/01 01:19AM
  Re: Now I did it!Re: Ron Brown Ron Brown 06/25/01 01:22AM
  Re: Now I did it!Re: Brian Allen Brian Allen 06/25/01 01:51AM
  Re: Now I did it!Re: Ron Brown Ron Brown 06/25/01 10:31AM
  Re: Now I did it!Re: Brian Brian 06/25/01 12:01PM
  Re: Now I did it!Re: Ron Brown Ron Brown 06/25/01 12:23PM
  Re: Now I did it!Re: Michael L. Michael L. 06/25/01 02:21AM
  Re: Now I did it!Re: Ron Brown Ron Brown 06/25/01 10:34AM
  Re: Now I did it!Re: Chris Robertson Chris Robertson 06/26/01 10:58AM
  Re: Now I did it!Re: Ron Brown Ron Brown 06/26/01 12:38PM
  Re:they're called..Re: Jim C. Jim C. 06/25/01 11:28PM
  Re:they're called..Re: Ron Brown Ron Brown 06/26/01 12:27PM

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account