Re: Help !! Spree wont run right

Chris Robertson /
This single post is part of a larger thread. Start from the top or view this post in context.

I had a moped whose clutch would slip. It sounds and feels exactly like the engine dies. When the moped slowed down, the clutch would begin to grab again and power would resume.

Assuming Sprees are automatic and have a dry clutch, you should take apart your clutch, and sand away the shine from the clutch pads and drum with 100 grit sandpaper. Spray it clean with brake parts cleaner.

The procedure I just outlined, of course, doesn't apply if your Spree does not have a dry clutch.

Chris.

This single post is part of a larger thread. Start from the top or view this post in context.
Subject Written By Posted
  Help !! Spree wont run rightTopic by: Dave in Naples Dave in Naples 06/04/01 08:50AM
  Re: Help !! Spree wont run rightRe: Chris Robertson Chris Robertson 06/04/01 11:30AM
  Re: Help !! Spree wont run rightRe: Ron Brown Ron Brown 06/04/01 11:55AM
  Re: Help !! Spree wont run rightRe: Ron Brown Ron Brown 06/04/01 11:58AM
  Re: Help !! Spree wont run rightRe: Chris Robertson Chris Robertson 06/04/01 12:24PM
  Re: Help !! Spree wont run rightRe: Fred Fred 06/04/01 01:17PM
  Re: Help !! Spree wont run rightRe: Reeperette Reeperette 06/04/01 02:16PM
  Re: Help !! Spree wont run rightRe: don-ohio don-ohio 06/04/01 04:39PM
  Re: Help !! Spree wont run rightRe: Michael Michael 06/04/01 08:41PM
  Re: Help !! Spree wont run rightRe: don-ohio don-ohio 06/05/01 12:21PM
  Re: Help !! Spree wont run rightRe: Ron Brown Ron Brown 06/05/01 04:00PM
  Re: Help !! Spree wont run rightRe: don-ohio don-ohio 06/05/01 04:55PM

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account